Select Elements Service
Class full path: NemAll_Python_IFW_Input.SelectElementsService
Classes
eSelectCondition
Bases: IntEnum
Element selection condition
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
Union[str, int, float]
|
value key |
required |
Returns:
Type | Description |
---|---|
eSelectCondition
|
value for the key |
Functions
SelectByPolygon(doc, polygon, viewProjection, selCond, filter)
staticmethod
Select an element by a point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
polygon
|
Polygon2D
|
surrounding search polygon (view coordinates) |
required |
viewProjection
|
ViewWorldProjection
|
Identification of view projection (window) |
required |
selCond
|
eSelectCondition
|
True when elements inside rectangle must be selected only |
required |
filter
|
SelectionQuery
|
Selection filter |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Data of the selected elements |
SelectByRect(doc, cursorLeftBottomPoint, cursorRightTopPoint, viewProjection, selCond, filter)
staticmethod
Select an element by a point
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
cursorLeftBottomPoint
|
Point2D
|
Coordinate of left bottom point where elements will be searching |
required |
cursorRightTopPoint
|
Point2D
|
Coordinate of right top point where elements will be searching |
required |
viewProjection
|
ViewWorldProjection
|
Identification of view projection (window) |
required |
selCond
|
eSelectCondition
|
True when elements inside rectangle must be selected only |
required |
filter
|
SelectionQuery
|
Selection filter |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Data of the selected elements |