Selection Query
Class full path: NemAll_Python_IFW_Input.SelectionQuery
Implementation of the selection query
Functions
Clear()
Clear the query
IsEmpty()
Check for an empty query
Returns:
Type | Description |
---|---|
bool
|
Filter is empty: true/false |
__init__
overload
__init__()
initialize
__init__(query)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
query
|
SelectionQuery
|
Query to copy |
required |
__init__(query)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
query
|
Union[List[Union[QueryTypeID, object]], QueryTypeID, object]
|
Selection query as list with queries or single query. The queries can be a QueryTypeID object or a callable class (a class with a call member). If you want to use a callable class as a filter, the call function has to be defined exacly as in the QueryTypeID object: one input argument of type BaseElementAdapter and one return a bool value. See documentation for the QueryTypeID class. |
required |