Fixture Properties
Class full path: NemAll_Python_Palette.FixtureProperties
Attributes
Element: None
property
Property access for the element
:type: None
Group: None
property
Property access for the group
:type: None
Path: None
property
Property access for the path
:type: None
PathShortcut: None
property
Property access for the path shortcut
:type: None
Functions
GetElement()
Get the element
Returns:
Type | Description |
---|---|
str
|
Element |
GetGroup()
Get the group
Returns:
Type | Description |
---|---|
str
|
Group |
GetPath()
Get the path
Returns:
Type | Description |
---|---|
str
|
Path |
__eq__(other)
Comparison of fixture properties.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
other
|
FixtureProperties
|
Compared fixture properties. |
required |
Returns:
Type | Description |
---|---|
object
|
True when fixture properties are equal, otherwise false. |
__repr__()
convert the list to a string