Fixture Placement Properties
Class full path: NemAll_Python_Precast.FixturePlacementProperties
Representation of properties of a fixture placement
Attributes
Automation: bool
property
Property for automation
ConnectionToAIACatalog: bool
property
Property for connection to AIACatalog
ConnectionToAllplanCatalog: bool
property
Property for connection to AllplanCatalog
CountOfQuestions: int
property
Property for count of questions
DistortionState: bool
property
Property for distortion state
DomainType: int
property
Property for domain type
EnableQuestions: bool
property
Property for enable questions
HasParentModificationBehaviour: bool
property
Property for specific behavior for modification state
HeightDefinitionType: HeightDefinitionType
property
Property for height definition types
HollowShaft: bool
property
Property for hollow shaft
Mass_V6: float
property
Property for V6 attribute
Mass_V7: float
property
Property for V7 attribute
Mass_V8: float
property
Property for V8 attribute
Mass_V9: float
property
Property for V9 attribute
Matrix: Matrix3D
property
Property for placement matrix. Specifies location in world coordinate system
MirrorState: bool
property
Property for the fixture placement mirrored state
Name: str
property
Property for name
OutlineShape: OutlineShape
property
Property for outline shape
OutlineType: OutlineType
property
Property for outline type
OutlineTypeInGroup: OutlineTypeInGroup
property
Property for outline type in group
PositionNr: int
property
Property for position number
ProfilType: ProfilType
property
Property for profile type
SubType: SubType
property
Property for fixture sub type
Type: Type
property
Property for fixture type
UnitFactor: float
property
Property for unit factor
UseAlways2DRepInGroundView: bool
property
Property for state if always 2D representation in ground view is shown
UseDrawOrder: bool
property
Whether the draw order setting should be defined by the placement (True) or by the elements of the fixture slide (False)
UseFormat: bool
property
Whether the the format settings (pen, stroke, color) should be defined by the placement (True) or by the elements of the fixture slide (False)
Visibility: int
property
Property for visibility
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
FixturePlacementProperties
|
Properties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
convert the list to a string