Fixture Slide Element
Class full path: NemAll_Python_Precast.FixtureSlideElement
Bases: PrecastElement
, AllplanElement
Representation of fixture slide
Functions
GetFixtureSlideProperties()
Get the properties
Returns:
Type | Description |
---|---|
FixtureSlideProperties
|
Fixture slide properties |
GetObjectList()
Get the slide object list
Returns:
Type | Description |
---|---|
List
|
List of model objects in the slide |
SetFixtureSlideProperties(FixtureSlideProp)
Set the properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
FixtureSlideProp
|
FixtureSlideProperties
|
Fixture slide properties |
required |
__init__
overload
__init__()
initialize
__init__(FixtureSlideProp, objectList)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
FixtureSlideProp
|
FixtureSlideProperties
|
Properties |
required |
objectList
|
List
|
List of model objects in the slide |
required |
__repr__()
convert the list to a string