Precast Layer Properties
Class full path: NemAll_Python_Precast.PrecastLayerProperties
PrecastLayerProperties class
Attributes
LayerName: str
property
Property for Layer Name
LayerNumber: int
property
Property for Layer Number
LayerThickness: float
property
Property for Layer Thickness
Material: str
property
Property for Material
MaterialCatAddressOffset: int
property
Property for Material Catalog Address Offset
MaterialType: int
property
Property for Material Type
Functions
SetMaterialCatalogAddressOffset(materialType, materialName)
Set the Material Catalog Address Offset
Parameters:
Name | Type | Description | Default |
---|---|---|---|
materialType
|
str
|
name of the material type |
required |
materialName
|
str
|
name of the material |
required |
Returns:
Type | Description |
---|---|
int
|
Material Catalog Address Offset |
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
PrecastLayerProperties
|
Properties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
initialize
__repr__()
Convert to string