Type
Class full path: NemAll_Python_Precast.Type
Bases: IntEnum
Enumeration class containing fixture types
Attributes:
Name | Type | Description |
---|---|---|
ePoint_Fixture |
int
|
Point fixture |
eLine_Fixture |
int
|
Linear fixture |
ePlane_Fixture |
int
|
Surface fixture |
eGroup_Fixture |
int
|
Fixture group |
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
Union[str, int, float]
|
value key |
required |
Returns:
Type | Description |
---|---|
Type
|
value for the key |