Bars Operations
Class full path: NemAll_Python_Reinforcement.BarsOperations
Functions
DivideBarsPlacement(placement, divideParameters, divisionPolyline)
staticmethod
Divide the bars placement
Returns:
Type | Description |
---|---|
str
|
Result message |
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
BaseElementAdapter
|
Bar placement to divide |
required |
divideParameters
|
DivideBarsParameters
|
Parameters of the division |
required |
divisionPolyline
|
Polyline2D
|
Divison polyline |
required |
JoinBarsPlacements(placement, fillEdges)
staticmethod
Join the bars placements
Returns:
Type | Description |
---|---|
str
|
Result message |
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placement
|
BaseElementAdapterList
|
BaseElementAdapterList with the placements |
required |
fillEdges
|
bool
|
Fill the edges: True/False |
required |
__init__()
initialize