Mesh Area Placement Service
Class full path: NemAll_Python_Reinforcement.MeshAreaPlacementService
Functions
AddOpeningPolygon(openingPol, offset)
Add an opening polygon
Parameters:
Name | Type | Description | Default |
---|---|---|---|
openingPol
|
Polygon3D
|
Opening polygon |
required |
offset
|
float
|
Offset from the polygon |
required |
Calculate(arg2, doc, mesh, placementMatrix, startPositionNumber, concreteCoverZDir)
Calculate the meshes
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
MeshData
|
Document |
required |
mesh
|
MeshAreaPlacementProperties
|
Mesh data |
required |
placementMatrix
|
Matrix3D
|
Placement matrix |
required |
startPositionNumber
|
int
|
Start position number |
required |
concreteCoverZDir
|
float
|
Concrete cover in the local z direction |
required |
SetOuterPolygon(placementPol, offset)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placementPol
|
Polygon3D
|
Placement polygon |
required |
offset
|
float
|
Offset from the polygon |
required |
__init__()
initialize