Reinforcement Service
Class full path: NemAll_Python_Reinforcement.ReinforcementService
Reinforcement service
Classes
BarShapeCodeStandard
Bases: IntEnum
Standard for the bar shape code
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
Union[str, int, float]
|
value key |
required |
Returns:
Type | Description |
---|---|
BarShapeCodeStandard
|
value for the key |
Functions
GetACIBarMark(barsDefinitionElement, showIndex)
staticmethod
Get the bar mark
Parameters:
Name | Type | Description | Default |
---|---|---|---|
barsDefinitionElement
|
BaseElementAdapter
|
Bars definition element |
required |
showIndex
|
bool
|
Show the index |
required |
Returns:
Type | Description |
---|---|
List
|
bar mark for ACI |
GetACIPlacementBarMark(barsPlacementElement, showIndex)
staticmethod
Get the bar mark for a placement
Parameters:
Name | Type | Description | Default |
---|---|---|---|
barsPlacementElement
|
BaseElementAdapter
|
Bars placement element |
required |
showIndex
|
bool
|
Show the index |
required |
Returns:
Type | Description |
---|---|
List[str]
|
bar mark for ACI |
int
|
bar count |
GetBarPositionData(elementVec)
staticmethod
Get the bar position data
Parameters:
Name | Type | Description | Default |
---|---|---|---|
elementVec
|
BaseElementAdapterList
|
GUID vector with the elements |
required |
Returns:
Type | Description |
---|---|
List[BarPositionData]
|
List with the bar position data |
GetBarShapeCode(barsDefinitionElement, barShapeCodeStandard)
staticmethod
Get the bar shape code
Parameters:
Name | Type | Description | Default |
---|---|---|---|
barsDefinitionElement
|
BaseElementAdapter
|
Bars definition element (BarsDefinition_TypeUUID) |
required |
barShapeCodeStandard
|
BarShapeCodeStandard
|
Standard for the bar shape code |
required |
Returns:
Type | Description |
---|---|
int
|
shape code count, |
Union[Tuple[str, float], List[int]]
|
list of tuples(shape codes, bar length) for ACI standard or list of shape codes for all other |
List[Union[Tuple[str, float], List[float]]]
|
list of tuples(segment name, segment lengths) for ACI standard, list of lengths for all other |