Reinforcement Shape Builder
Class full path: NemAll_Python_Reinforcement.ReinforcementShapeBuilder
Implementation of the reinforcement shape builder
Functions
AddPoint
overload
AddPoint(pnt, concreteCover, bendingRoller, zCoordBar=0)
Add an end point of a geometry side
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pnt
|
Point2D
|
End point of the side |
required |
concreteCover
|
float
|
Concrete cover |
required |
bendingRoller
|
float
|
Bending roller |
required |
zCoordBar
|
float
|
Bar coordinate in z direction of the local shape coordinate system |
0
|
AddPoint(pnt, concreteCover, bendingRoller)
Add an end point of a geometry side
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pnt
|
Point3D
|
End point of the side |
required |
concreteCover
|
float
|
Concrete cover |
required |
bendingRoller
|
float
|
Bending roller |
required |
AddPoints(pointList)
Add the shape geometry points
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pointList
|
object
|
Point list |
required |
AddSide
overload
AddSide(startPnt, endPnt, concreteCover, bendingRoller, zCoordBar=0)
Add a geometry side of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startPnt
|
Point2D
|
Start point of the geometry side |
required |
endPnt
|
Point2D
|
End point of the geometry side |
required |
concreteCover
|
float
|
Concrete cover |
required |
bendingRoller
|
float
|
Bending roller between the last and current side |
required |
zCoordBar
|
float
|
Bar coordinate in z direction of the local shape coordinate system |
0
|
AddSide(startPnt, endPnt, concreteCover, bendingRoller)
Add a geometry side of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startPnt
|
Point3D
|
Start point of the geometry side |
required |
endPnt
|
Point3D
|
End point of the geometry side |
required |
concreteCover
|
float
|
Concrete cover |
required |
bendingRoller
|
float
|
Bending roller between the last and current side |
required |
AddSides(sideList)
Add the geometry sides of a shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
sideList
|
object
|
Side list |
required |
CreateShape
overload
CreateShape(diameter, bendingRoller, steelGrade, concreteGrade, bendingShapeType)
Create the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
diameter
|
float
|
Diameter |
required |
bendingRoller
|
float
|
Default bending roller |
required |
steelGrade
|
int
|
Steel grade |
required |
concreteGrade
|
int
|
Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings) |
required |
bendingShapeType
|
BendingShapeType
|
Bending shape type |
required |
Returns:
Type | Description |
---|---|
BendingShape
|
Creation successful: true/false |
CreateShape(meshType, meshBendingDirection, bendingRoller, steelGrade, concreteGrade, bendingShapeType)
Create the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
meshType
|
str
|
Mesh type |
required |
meshBendingDirection
|
MeshBendingDirection
|
Mesh bending direction |
required |
bendingRoller
|
float
|
Default bending roller |
required |
steelGrade
|
int
|
Steel grade |
required |
concreteGrade
|
int
|
Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings) |
required |
bendingShapeType
|
BendingShapeType
|
Bending shape type |
required |
Returns:
Type | Description |
---|---|
BendingShape
|
Creation successful: true/false |
CreateShape(shapeProps)
Create the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shapeProps
|
object
|
Shape properties |
required |
Returns:
Type | Description |
---|---|
BendingShape
|
Creation successful: true/false |
CreateStirrup
overload
CreateStirrup(diameter, bendingRoller, steelGrade, concreteGrade, stirrupType)
Create the stirrup shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
diameter
|
float
|
Diameter |
required |
bendingRoller
|
float
|
Default bending roller |
required |
steelGrade
|
int
|
Steel grade |
required |
concreteGrade
|
int
|
Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings) |
required |
stirrupType
|
StirrupType
|
Type of the stirrup |
required |
Returns:
Type | Description |
---|---|
BendingShape
|
Creation successful: true/false |
CreateStirrup(meshType, meshBendingDirection, bendingRoller, steelGrade, concreteGrade, stirrupType)
Create the stirrup shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
meshType
|
str
|
Mesh type |
required |
meshBendingDirection
|
MeshBendingDirection
|
Mesh bending direction |
required |
bendingRoller
|
float
|
Default bending roller |
required |
steelGrade
|
int
|
Steel grade |
required |
concreteGrade
|
int
|
Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings) |
required |
stirrupType
|
StirrupType
|
Type of the stirrup |
required |
Returns:
Type | Description |
---|---|
BendingShape
|
Creation successful: true/false |
CreateStirrup(shapeProps, stirrupType)
Create the stirrup shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shapeProps
|
object
|
Shape properties |
required |
stirrupType
|
StirrupType
|
Type of the stirrup |
required |
Returns:
Type | Description |
---|---|
BendingShape
|
Creation successful: true/false |
GetMeshData(meshType)
staticmethod
Get the mesh data
Parameters:
Name | Type | Description | Default |
---|---|---|---|
meshType
|
str
|
Mesh type |
required |
Returns:
Type | Description |
---|---|
MeshData
|
Mesh data |
SetAnchorageHookEnd(angle)
Set an anchorage hook at the end of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
angle
|
float
|
Hook angle |
required |
SetAnchorageHookEndFromSide()
Set an anchorage hook at the end of the shape, get the angle from the side
SetAnchorageHookStart(angle)
Set an anchorage hook at the start of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
angle
|
float
|
Hook angle |
required |
SetAnchorageHookStartFromSide()
Set an anchorage hook at the start of the shape, get the angle from the side
SetAnchorageLengthEnd(anchorageLength)
Set the anchorage length at the end of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
anchorageLength
|
float
|
Anchorage length at the end of the shape |
required |
SetAnchorageLengthStart(anchorageLength)
Set the anchorage length at the start of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
anchorageLength
|
float
|
Anchorage length at the start of the shape |
required |
SetConcreteCoverEnd(concreteCover)
Set the concrete cover at the end of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
concreteCover
|
float
|
Concrete cover |
required |
SetConcreteCoverLineEnd
overload
SetConcreteCoverLineEnd(startPnt, endPnt, concreteCover)
Set the concrete cover line at the end of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startPnt
|
Point2D
|
Start point of the concrete cover line at the end of the shape |
required |
endPnt
|
Point2D
|
Endpoint of the concrete cover line at the end of the shape |
required |
concreteCover
|
float
|
Concrete cover |
required |
SetConcreteCoverLineEnd(startPnt, endPnt, concreteCover)
Set the concrete cover line at the end of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startPnt
|
Point3D
|
Start point of the concrete cover line at the end of the shape |
required |
endPnt
|
Point3D
|
Endpoint of the concrete cover line at the end of the shape |
required |
concreteCover
|
float
|
Concrete cover |
required |
SetConcreteCoverLineStart
overload
SetConcreteCoverLineStart(startPnt, endPnt, concreteCover)
Set the concrete cover line at the start of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startPnt
|
Point2D
|
Start point of the concrete cover line at the start of the shape |
required |
endPnt
|
Point2D
|
Endpoint of the concrete cover line at the start of the shape |
required |
concreteCover
|
float
|
Concrete cover |
required |
SetConcreteCoverLineStart(startPnt, endPnt, concreteCover)
Set the concrete cover line at the start of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startPnt
|
Point3D
|
Start point of the concrete cover line at the start of the shape |
required |
endPnt
|
Point3D
|
Endpoint of the concrete cover line at the start of the shape |
required |
concreteCover
|
float
|
Concrete cover |
required |
SetConcreteCoverStart(concreteCover)
Set the concrete cover at the start of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
concreteCover
|
float
|
Concrete cover |
required |
SetFullCircleOverlap(fullCircleOverlap)
Set the overlap length for the full circle stirrup
Parameters:
Name | Type | Description | Default |
---|---|---|---|
fullCircleOverlap
|
float
|
Overlap length |
required |
SetHookEnd(length, angle, type)
Set the hook at the end of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
length
|
float
|
Hook length (0 = calculate) |
required |
angle
|
float
|
Hook angle |
required |
type
|
HookType
|
Hook type |
required |
SetHookStart(length, angle, type)
Set the hook at the start of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
length
|
float
|
Hook length (0 = calculate) |
required |
angle
|
float
|
Hook angle |
required |
type
|
HookType
|
Hook type |
required |
SetOverlapLengthEnd()
Set an overlap length at the end of the shape
SetOverlapLengthStart()
Set an overlap length at the start of the shape
SetSideLengthEnd(sideLength)
Set the side length at the end of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
sideLength
|
float
|
Side length |
required |
SetSideLengthStart(sideLength)
Set the side length at the start of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
sideLength
|
float
|
Side length |
required |
SetStartPoint
overload
SetStartPoint(startPnt)
Set a start point of a geometry side
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startPnt
|
Point2D
|
Start point |
required |
SetStartPoint(startPnt)
Set a start point of a geometry side
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startPnt
|
Point3D
|
Start point |
required |
__init__
overload
__init__()
initialize
__init__(shapePlaneMatrix)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shapePlaneMatrix
|
Matrix3D
|
Matrix of the plane for the real shape calculation |
required |
__init__(shapePlaneMatrix, create3DShape, localZCoverFront, localZCoverBack)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shapePlaneMatrix
|
Matrix3D
|
Matrix of the plane for the real shape calculation |
required |
create3DShape
|
bool
|
Create a 3D shape |
required |
localZCoverFront
|
float
|
Concrete cover in the front of the local z direction of the shape (needed for 3D shape) |
required |
localZCoverBack
|
float
|
Concrete cover in the back of the local z direction of the shape (needed for 3D shape) |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
ReinforcementShapeBuilder
|
Element to copy |
required |