Release Notes
Allplan 2023-1-4
- New articles in the Manual -> Features -> Geometry
- Objects overview about the essential objects of the NemAll_Python_Geometry module
- Solids about creating volumetric objects (including new examples)
- Transformation about the essential transformation operations (move, rotate, scale, mirror)
- New empty script templates available in \Etc\PythonPartsFramework\PythonPartsScriptTemplates\ for easier creation of PythonPart scripts
- New property: LengthFactor in following reinforcement objects:
- Reading the DrawOrder property from the CommonProperties object resulted in a value being 15 higher than expected. This is fixed now.
Allplan 2023-1-3
- Introduced new functionality in the API: Section Along Path.
See new example under:
BasisExamples\ObjectCreation\SectionAlongPath
. - Introduced new tag
<XYZinRow>
for geometry parameters. See here for more details - Individual text for each coordinate in a geometry parameter is now possible.
- In a geometry parameter it is now possible to control the visibility of controls of individual coordinates.
- Using
$list_row
is now possible in the<TextDyn>
tag - Palette examples were divided into smaller and simpler ones. See \etc\Examples\PythonParts\PaletteExamples\
-
Introduced new classes in the PythonPartsFramework:
- ModelEleList - for easier creation of lists of ModelElement3D and ModelElement2D
- PolyhedronTypesList for easier creation of lists of Polyhedron3D and
- PythonPartParameterUtil - for creating labels based on PythonParts parameters
-
New method SetLabeledElement of LabelElement for labeling existing Allplan elements
Allplan 2023-1-2
- new examples for boolean geometry operations are added (see GeometryExamplesBooleanOperations)
- access to the Allplan polygon input
Allplan 2023-1-1
- new value type for a parameter with a dynamic attribute ID
- new tags for creating dynamic text in the property palette
- new tag for including a XML language file
Allplan 2023-1-0
- API function for copying elements
- access to the Allplan polyline input
- enable the use of a Button in Group parameter with a Python list
- extend the LibraryElement
- enable the use of short cuts to initialize a path to the Allplan standard folders File dialogs
- new value type: CommonProperties
- allow to create constraints between a height and plane references Plane references dialog
- introduced constants
- new service for face selection
- new service: Handle properties service
- use the VSCode - Pylint extension in Editing with Visual Studio Code
- introduced Pylint extension PythonPartPylintExtension to check the PythonPart script code
Allplan 2023-0-7
- create a surface definition with bitmaps
- create RadioButton from a list of namedtuple
- add example for Export and Import of IFC data
- extend the class BottomTopPlaneService for access to the surface planes
- add documentation and example for List handles
Allplan 2023-0-5
- extended ReinforcementShapeBuilder for 3D bar shape creation
- new functionality for CAD data export and import to the Python-API to use existing CAD data content directly in Allplan (see the documentation for IFC and other formats)
- extended classes and functions fo rattribute management (see the documentation for element attributes or project attributes)
Allplan 2023-0-3
- new member function on_cancel_by_menu_function See the manual
- new reinforcement placements: ExtrudeBarPlacement and SweepBarPlacement
Allplan 2023-RC2
Applies also to 2022-1-5
- Docking points (e.g., for associative dimension lines)
Allplan 2022-1-9
- new value type
AttributeIdValue
for static or dynamic attribute input parameter with an attribute ID - new class PythonPartTransaction for interactor PythonParts (learn more)
- new value type for parameter with any value by type
- new tag BackgroundColor for input fields of edit controls
- new property show_handles of the class HandleProperties to use only the input by the edit fields
- new feature of the API: hidden calculation
Allplan 2022-1-8
- new methods of BaseElementAdapter class for accessing the ground view and pure object geometry of architecture elements
- added the documentation for general Allplan model access classes: document adapter and element adapter
- added a new service for the handle modification in an Interactor PythonPart: HandleModificationService
Allplan 2022-1-7
- Attribute parameter value adjustment
- rotation handle extended for 3D rotation
- added a weblink to a button
- use the entire row for the controls
- multi line condition for enable and visible options
- formula for the dimensions tag of the Parameter with a Python list
Allplan 2022-1-6
- create and use static geometry
- Execute a PythonPart script created by VisualScripting
Allplan 2022-1-5
- introduced preview symbols
- use value of the
<IntervalValue>
tag as grid length for handles - dynamic property palette: get the index of the active palette page
- added PythonPart InstallPythonPackage
- Interactor PythonPart profiling with cProfile
- dynamic value list by expressions
- dynamic minimal and/or maximal value by Python expressions
- new tags for setting up the text style
- new tags for setting up the the size of input controls in the palette
- new value dialog keywords for file dialog
Allplan 2022-1-4
- new value type ListGroup for grouping the parameters with a Python list
- extensions for update of identical PythonParts
- extended API function ServiceMirror for BRep3D
Allplan 2022-1-3
- new value type for parameter with an attribute ID
- use the
<ValueList>
tag in edit controls Value and ValueList - use of integer, float or string for RadioButton
- new class CreateElementResult as return value of the create_element function allows multi and global PythonPart placement
- new functions for creating a Dynamic property palette
- new class ControlPropertiesUtil for the adaption of the data for the property palette controls
- new possibilities for the enable and visible options of the property palette controls
- introduced performance profiling of the PythonPart
- show a parameter on multiple pages Parameter node
Allplan 2022-1-2
- introduced plane connections
Allplan 2022-1
- introduced encryping the PythonPart source code
- tags
<Enable>
and<Visible>
now available also for the page node - new value type: weight
- new function for parameter migration
- a PythonPart can now be runned from the command line
Allplan 2022-0
- new features for parameter with a Python namedtuple
- new handle types and extended handle functionality