Allplan Paths
Class full path: NemAll_Python_AllplanSettings.AllplanPaths
Class for getting Allplan paths
Functions
GetCurPrjDesignPath()
staticmethod
Get the current project design path
Returns:
Type | Description |
---|---|
str
|
Current project design path |
GetCurPrjPath()
staticmethod
Get the current project path
Returns:
Type | Description |
---|---|
str
|
Current project path |
GetEtcPath()
staticmethod
Get the Etc path
Returns:
Type | Description |
---|---|
str
|
Etc path |
GetPathOfApplication()
staticmethod
Get the path of the application
Returns:
Type | Description |
---|---|
str
|
Path of the application |
GetPrgPath()
staticmethod
Get the program path
Returns:
Type | Description |
---|---|
str
|
Program path |
GetPythonPartsEtcPath()
staticmethod
Get the PythonParts Etc path
Returns:
Type | Description |
---|---|
str
|
Etc path |
GetStdDesignPath()
staticmethod
Get the Std design path
Returns:
Type | Description |
---|---|
str
|
Std design path |
GetStdPath()
staticmethod
Get the Std path
Returns:
Type | Description |
---|---|
str
|
Std path |
GetTmpPath()
staticmethod
Get the Tmp path
Returns:
Type | Description |
---|---|
str
|
Tmp path |
GetUsrPath()
staticmethod
Get the Usr path
Returns:
Type | Description |
---|---|
str
|
Usr path |