Allplan Version
Class full path: NemAll_Python_AllplanSettings.AllplanVersion
Class for extraction of Allplan version information
Functions
MainReleaseName()
staticmethod
Get the Allplan main release name Returns: Allplan main release name ('2016', '2017', ...)
SubReleaseName()
staticmethod
Get the Allplan sub release name Returns: Allplan sub release name ('2016.0', '2016.1', ...)
Version()
staticmethod
Get the Allplan version as string Returns: Allplan version 2016.1 2016: Allplan main version .1: Allplan sub version
2016.1.1 2016: Allplan main version .1.1: Allplan sub version
WindowsReleaseName()
staticmethod
Get the Allplan window release name Returns: 'P' for project version or empty string for the normal version