Imperial Unit Service
Class full path: NemAll_Python_AllplanSettings.ImperialUnitService
Imperial unit service
Functions
ConvertToMM(imperialValue)
staticmethod
Convert an imperial length unit to mm
Parameters:
Name | Type | Description | Default |
---|---|---|---|
imperialValue
|
str
|
Imperial value as string |
required |
Returns:
Type | Description |
---|---|
tuple
|
Length in mm |
ConvertTokg(imperialValue)
staticmethod
Convert an imperial weight unit to kg
Parameters:
Name | Type | Description | Default |
---|---|---|---|
imperialValue
|
str
|
Imperial value as string |
required |
Returns:
Type | Description |
---|---|
tuple
|
Weight in kg |
IsImperialUnit()
staticmethod
Check whether the current input unit is imperial unit
Returns:
Type | Description |
---|---|
bool
|
Imperial unit input: True/False |