Arch Base Properties
Class full path: NemAll_Python_ArchElements.ArchBaseProperties
Implementation of the architecture base properties
Attributes
BackgroundColor: int
property
writable
Get the background color
BitmapName: str
property
writable
Get the name of the bitmap
CalculationMode: int
property
writable
Get the calculation model
CircleDivision: float
property
writable
Get the circle division
CommonProperties: NemAll_Python_BaseElements.CommonProperties
property
writable
Get the common properties
FaceStyle: int
property
writable
Get the face style ID
Factor: float
property
writable
Get the factor
Filling: int
property
writable
Get the filling ID
Hatch: int
property
writable
Get the hatch ID
Material: str
property
writable
Get the material
Name: str
property
writable
Get the name
Pattern: int
property
writable
Get the pattern ID
PlaneReferences: PlaneReferences
property
writable
Get the plane references
Priority: int
property
writable
Get the priority
ProfileFullName: str
property
writable
Get the full name of the profile
Surface: str
property
writable
Get the surface name and path
Trade: int
property
writable
Get the trade index
Classes
ShapeType
Bases: IntEnum
Shape types
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
ShapeType
|
value for the key |
Functions
GetAreaPresentationID()
Get the ID of the area representation
Returns:
Type | Description |
---|---|
int
|
ID of the area representation |
GetAreaPresentationType()
Get the type of the area representation
Returns:
Type | Description |
---|---|
int
|
Type of the area representation |
GetBackgroundColor()
Get the background color
Returns:
Type | Description |
---|---|
int
|
Background color |
GetBitmapName()
Get the name of the bitmap
Returns:
Type | Description |
---|---|
str
|
Name of the bitmap |
GetCalculationMode()
Get the calculation model
Returns:
Type | Description |
---|---|
int
|
Calculation model |
GetCircleDivision()
Get the circle division
Returns:
Type | Description |
---|---|
float
|
Circle division |
GetCommonProperties()
Get the common properties
Returns:
Type | Description |
---|---|
CommonProperties
|
Common properties |
GetFaceStyle()
Get the face style ID
Returns:
Type | Description |
---|---|
int
|
Face style ID |
GetFactor()
Get the factor
Returns:
Type | Description |
---|---|
float
|
Factor |
GetFilling()
Get the filling ID
Returns:
Type | Description |
---|---|
int
|
Filling ID |
GetHatch()
Get the hatch ID
Returns:
Type | Description |
---|---|
int
|
Hatch ID |
GetMacroType()
Get the macro type
GetMaterial()
Get the material
Returns:
Type | Description |
---|---|
str
|
Material |
GetName()
Get the name
Returns:
Type | Description |
---|---|
str
|
Name |
GetPattern()
Get the pattern ID
Returns:
Type | Description |
---|---|
int
|
Pattern ID |
GetPlaneReferences()
Get the plane references
Returns:
Type | Description |
---|---|
PlaneReferences
|
Plane references |
GetPriority()
Get the priority
Returns:
Type | Description |
---|---|
int
|
Priority |
GetProfileFullName()
Get the full name of the profile
Returns:
Type | Description |
---|---|
str
|
Path and name of the profile |
GetShapeType()
Get the shape type
GetSurface()
Get the surface name and path
Returns:
Type | Description |
---|---|
str
|
Surface name and path |
GetTrade()
Get the trade index
Returns:
Type | Description |
---|---|
int
|
Trade index |
IsShowAreaElementInGroundView()
Get the 'Show the area element in the ground view' state
Returns:
Type | Description |
---|---|
bool
|
Show the area element in the ground view: true/false |
LoadFromFavoriteFile(doc)
Load the properties from the favorite file
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
RemoveCommonProperties()
Remove the common properties
ResetAreaElement()
Reset the area element
ResetBackgroundColor()
Reset the background color
SetBackgroundColor(colorID)
Set the background color
Parameters:
Name | Type | Description | Default |
---|---|---|---|
colorID
|
int
|
Background color ID |
required |
SetBitmapName(bitmapName)
Set the name of the bitmap
Parameters:
Name | Type | Description | Default |
---|---|---|---|
bitmapName
|
str
|
Bitmap name |
required |
SetCalculationMode(calculationMode)
Set the calculation mode
Parameters:
Name | Type | Description | Default |
---|---|---|---|
calculationMode
|
int
|
Calculation mode |
required |
SetCircleDivision(circleDivision)
Set the circle division
Parameters:
Name | Type | Description | Default |
---|---|---|---|
circleDivision
|
int
|
Circle division |
required |
SetCommonProperties(comProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
comProp
|
CommonProperties
|
Common properties |
required |
SetFaceStyle(faceStyleID)
Set the face style
Parameters:
Name | Type | Description | Default |
---|---|---|---|
faceStyleID
|
int
|
Face style ID |
required |
SetFactor(factor)
Set the factor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
factor
|
float
|
Factor |
required |
SetFilling(fillingID)
Set the filling
Parameters:
Name | Type | Description | Default |
---|---|---|---|
fillingID
|
int
|
Filling ID |
required |
SetHatch(hatchID)
Set the hatch
Parameters:
Name | Type | Description | Default |
---|---|---|---|
hatchID
|
int
|
Hatch ID |
required |
SetMaterial(material)
Set the material
Parameters:
Name | Type | Description | Default |
---|---|---|---|
material
|
str
|
Material |
required |
SetName(name)
Set the name
Parameters:
Name | Type | Description | Default |
---|---|---|---|
name
|
str
|
Name |
required |
SetPathElementAxisType(pathEleGeoType)
Set the axis type of the path element
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pathEleGeoType
|
int
|
Axis type of the path element |
required |
SetPattern(patternID)
Set the pattern
Parameters:
Name | Type | Description | Default |
---|---|---|---|
patternID
|
int
|
Pattern ID |
required |
SetPlaneReferences(planeRef)
Set the plane references
Parameters:
Name | Type | Description | Default |
---|---|---|---|
planeRef
|
PlaneReferences
|
Plane references |
required |
SetPriority(priority)
Set the priority
Parameters:
Name | Type | Description | Default |
---|---|---|---|
priority
|
int
|
Priority |
required |
SetProfileFullName(fullName)
Set the full name of the profile
Parameters:
Name | Type | Description | Default |
---|---|---|---|
fullName
|
str
|
Path and name of the profile |
required |
SetShapeType(shapeType)
Set the type of the shape
Parameters:
Name | Type | Description | Default |
---|---|---|---|
shapeType
|
ShapeType
|
Shape type |
required |
SetShowAreaElementInGroundView(showInGroundView)
Set the show area element in ground view state
Parameters:
Name | Type | Description | Default |
---|---|---|---|
showInGroundView
|
bool
|
Show the area element in the ground view |
required |
SetSurface(surface)
Set the surface
Parameters:
Name | Type | Description | Default |
---|---|---|---|
surface
|
str
|
Surface |
required |
SetTrade(value)
Set the trade
Parameters:
Name | Type | Description | Default |
---|---|---|---|
value
|
int
|
Trade index |
required |
ToString(indent)
Convert to string
Parameters:
Name | Type | Description | Default |
---|---|---|---|
indent
|
int
|
Indent |
required |
Returns:
Type | Description |
---|---|
str
|
String with tier properties |
__init__
overload
__init__()
Initialize
__init__(macroType)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
macroType
|
int
|
Macro type |
required |
__init__(baseProp)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
baseProp
|
ArchBaseProperties
|
Properties to copy |
required |