Arch Element
Class full path: NemAll_Python_ArchElements.ArchElement
Bases: AllplanElement
Implementation of the abstract base class ArchElement
Attributes
ConnectionUUID: NemAll_Python_IFW_ElementAdapter.GUID
property
writable
Get the connection UUID
Functions
GetConnectionUUID()
Get the connection UUID
Returns:
Type | Description |
---|---|
GUID
|
Connection UUID |
SetConnectionUUID(connectionGuid)
Set the connection UUID
Parameters:
Name | Type | Description | Default |
---|---|---|---|
connectionGuid
|
GUID
|
Connection UUID |
required |