Beam Element
Class full path: NemAll_Python_ArchElements.BeamElement
Bases: ArchElement
, AllplanElement
Implementation of the beam element
Attributes
Properties: BeamProperties
property
writable
Get the beam properties
Functions
GetProperties()
Get the beam properties
Returns:
Type | Description |
---|---|
BeamProperties
|
Beam properties |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
SetProperties(beamProp)
Set the beam properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
beamProp
|
BeamProperties
|
Beam properties |
required |
__init__
overload
__init__()
Initialize
__init__(beamProp, axis)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
beamProp
|
BeamProperties
|
Beam properties |
required |
axis
|
object
|
Axis |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
BeamElement
|
Element to copy |
required |
__repr__()
Convert to string