Property Dialogs
Class full path: NemAll_Python_ArchElements.PropertyDialogs
Functions
GetLastSymbolPath()
staticmethod
Get the last symbol path
Returns:
Type | Description |
---|---|
str
|
Last symbol path |
GetSymbolName(symbolPath)
staticmethod
Get the symbol name
Parameters:
Name | Type | Description | Default |
---|---|---|---|
symbolPath
|
str
|
Symbol path |
required |
Returns:
Type | Description |
---|---|
str
|
Symbol name |
GetTradeDescription(tradeID)
staticmethod
Get the trade description
Parameters:
Name | Type | Description | Default |
---|---|---|---|
tradeID
|
int
|
Trade ID |
required |
Returns:
Type | Description |
---|---|
str
|
Trade description |
OpenBottomPlaneReferenceDialog(refElement, doc, planeRefs)
staticmethod
Open the plane references dialog
Returns:
Type | Description |
---|---|
float
|
bottom height |
Parameters:
Name | Type | Description | Default |
---|---|---|---|
refElement
|
BaseElementAdapter
|
Reference element (empty element if not exist) |
required |
doc
|
DocumentAdapter
|
Document |
required |
planeRefs
|
PlaneReferences
|
Plane references |
required |
OpenPlaneReferencesDialog(refElement, doc, planeRefs)
staticmethod
Open the plane references dialog
Parameters:
Name | Type | Description | Default |
---|---|---|---|
refElement
|
BaseElementAdapter
|
Reference element (empty element if not exist) |
required |
doc
|
DocumentAdapter
|
Document |
required |
planeRefs
|
PlaneReferences
|
Plane references |
required |
OpenSymbolDialog(symbolPath)
staticmethod
Open the symbol library dialog
Returns:
Type | Description |
---|---|
str
|
result path |
Parameters:
Name | Type | Description | Default |
---|---|---|---|
symbolPath
|
str
|
Path to .sym file |
required |
OpenTopPlaneReferenceDialog(refElement, doc, planeRefs)
staticmethod
Open the plane references dialog
Returns:
Type | Description |
---|---|
float
|
top height |
Parameters:
Name | Type | Description | Default |
---|---|---|---|
refElement
|
BaseElementAdapter
|
Reference element (empty element if not exist) |
required |
doc
|
DocumentAdapter
|
Document |
required |
planeRefs
|
PlaneReferences
|
Plane references |
required |
OpenTradeDialog(doc, tradeID)
staticmethod
Open the trade dialog
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
tradeID
|
int
|
Current trade ID |
required |
Returns:
Type | Description |
---|---|
int
|
Trade ID |