Room Element
Class full path: NemAll_Python_ArchElements.RoomElement
Bases: ArchElement
, AllplanElement
Implementation of the Room element
Attributes
Properties: RoomProperties
property
writable
Get the Room properties
Functions
GetProperties()
Get the Room properties
Returns:
Type | Description |
---|---|
RoomProperties
|
Room properties |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
SetProperties(RoomProp)
Set the Room properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
RoomProp
|
RoomProperties
|
Room properties |
required |
__init__
overload
__init__()
Initialize
__init__(RoomProp, RoomPolygon)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
RoomProp
|
RoomProperties
|
Room properties |
required |
RoomPolygon
|
Polygon2D
|
Room polygon |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
RoomElement
|
Element to copy |
required |
__repr__()
Convert to string