Room Properties
Class full path: NemAll_Python_ArchElements.RoomProperties
Bases: ArchBaseProperties
Implementation of the Room properties
Attributes
Function: str
property
writable
Get the function
StoreyCode: str
property
writable
Get the storey code
Functions
GetAttributes(doc, onlyModifiable)
doc Document
onlyModifiable Only modifiable state
List with the attributes
GetFunction()
Get the function
Returns:
Type | Description |
---|---|
str
|
Function |
GetStoreyCode()
Get the storey code
Returns:
Type | Description |
---|---|
str
|
Storey code |
GetText(number)
Get the text
Parameters:
Name | Type | Description | Default |
---|---|---|---|
number
|
int
|
Number (1-5 allowed) |
required |
Returns:
Type | Description |
---|---|
str
|
Text |
SetAttribute(attrib)
Set the attribute
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attrib
|
Union[AttributeInteger, AttributeDouble, AttributeString, AttributeEnum]
|
Attribute |
required |
SetFunction(name)
Set the function
Parameters:
Name | Type | Description | Default |
---|---|---|---|
name
|
str
|
Function |
required |
SetStoreyCode(storeyCode)
Set the storey code
Parameters:
Name | Type | Description | Default |
---|---|---|---|
storeyCode
|
str
|
Storey code |
required |
SetText(text, number)
Set the text
Parameters:
Name | Type | Description | Default |
---|---|---|---|
text
|
str
|
Text |
required |
number
|
int
|
Number (1-5 allowed) |
required |
__init__
overload
__init__()
Initialize
__init__(RoomProp)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
RoomProp
|
RoomProperties
|
Room properties |
required |