Slab Element
Class full path: NemAll_Python_ArchElements.SlabElement
Bases: ArchElement
, AllplanElement
Implementation of the Slab element
Attributes
Properties: SlabProperties
property
writable
Get the Slab properties
Functions
GetProperties()
Get the Slab properties
Returns:
Type | Description |
---|---|
SlabProperties
|
Slab properties |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
SetProperties(SlabProp)
Set the Slab properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
SlabProp
|
SlabProperties
|
Slab properties |
required |
__init__
overload
__init__()
Initialize
__init__(slabProp, slabPolygon)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
slabProp
|
SlabProperties
|
Slab properties |
required |
slabPolygon
|
Polygon2D
|
Slab polygon |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
SlabElement
|
Element to copy |
required |
__repr__()
Convert to string