Slab Opening Element
Class full path: NemAll_Python_ArchElements.SlabOpeningElement
Bases: ArchElement
, AllplanElement
Implementation of the slab opening element
Attributes
Properties: SlabOpeningProperties
property
writable
Get the slab opening properties
Functions
GetProperties()
Get the slab opening properties
Returns:
Type | Description |
---|---|
SlabOpeningProperties
|
Slab opening properties |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
SetProperties(slabOpeningProp)
Set the SlabOpening properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
slabOpeningProp
|
SlabOpeningProperties
|
Slab opening properties |
required |
__init__
overload
__init__()
Initialize
__init__(slabOpeningProp, placementPoint, slabConnectionUUID)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
slabOpeningProp
|
SlabOpeningProperties
|
SlabOpening properties |
required |
placementPoint
|
object
|
Placement point |
required |
slabConnectionUUID
|
GUID
|
Connetion UUID of the slab |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
SlabOpeningElement
|
Element to copy |
required |
__repr__()
Convert to string