Structural Beam Properties
Class full path: NemAll_Python_ArchElements.StructuralBeamProperties
Bases: StructuralElementProperties
, ArchBaseProperties
Functions
GetEndPoint()
Get the end point of the element in world coordinate system
GetStartPoint()
Get the start point of the element in world coordinate system
SetAnchorPointProperties(anchorPointStart, offsetStart, anchorPointEnd, offsetEnd, twoAnchorPoints)
Set the Beam Anchor Points Properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
Values
|
for anchor point
|
1 - LeftBottom 2 - RightBottom 3 - RightTop 4 - LeftTop 5 - Center 6 - MiddleBottom 7 - MiddleRight 8 - MiddleTop 9 - MiddleLeft 10 - CenterOfGravity |
required |
SetEndPoint(x, y, z)
Set the end point of the element in world coordinate system
SetHeightProperties(doc, planeReferences)
Set HeightProperties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
PlaneReferences
|
Height Properties of Column, as PlaneReferences type |
required |
SetHeightPropsByPlacementPoints(doc, val, val1, val2)
Set HeightProperties
SetStartPoint(x, y, z)
Set the start point of the element in world coordinate system
__init__
overload
__init__()
Initialize
__init__(structuralBeamProps)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
structuralBeamProps
|
StructuralBeamProperties
|
Structural Beam properties |
required |