Structural Column Properties
Class full path: NemAll_Python_ArchElements.StructuralColumnProperties
Bases: StructuralElementProperties
, ArchBaseProperties
Functions
GetHeight()
Get the Column Height
Returns:
Type | Description |
---|---|
float
|
Height |
GetPosition()
Get the Column position in world coordinate system
Returns:
Type | Description |
---|---|
Point3D
|
Position |
SetAnchorPointProperties(val, point)
Set the Column Anchor Point Properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
val
|
int
|
Offset with Anchor Point Properties of Column |
required |
SetHeight(z, doc, val)
Set Column Height
Parameters:
Name | Type | Description | Default |
---|---|---|---|
val
|
PlaneReferences
|
height of Column |
required |
SetHeightProperties(doc, planeReferences)
Set the Column Height Properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
PlaneReferences
|
Height Properties of Column, as PlaneReferences type |
required |
SetHeightPropsByPlacementPoint(doc, val, val1)
Set HeightProperties
SetPosition(x, y, z)
Set the Column position in world coordinate system
Parameters:
Name | Type | Description | Default |
---|---|---|---|
val
|
position x,y,z of Column |
required |
__init__
overload
__init__()
Initialize
__init__(structuralColumnProps)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
structuralColumnProps
|
StructuralColumnProperties
|
Structural Column properties |
required |