Wall Element
Class full path: NemAll_Python_ArchElements.WallElement
Bases: ArchElement
, AllplanElement
Implementation of the wall element
Attributes
Properties: WallProperties
property
writable
Get the wall properties
Functions
GetProperties()
Get the wall properties
Returns:
Type | Description |
---|---|
WallProperties
|
Wall properties |
SetCommonProperties(commonProp)
Set the common properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
SetProperties(wallProp)
Set the wall properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
wallProp
|
WallProperties
|
Wall properties |
required |
__init__
overload
__init__()
Initialize
__init__(wallProp, axis)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
wallProp
|
WallProperties
|
Wall properties |
required |
axis
|
object
|
Axis |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
WallElement
|
Element to copy |
required |
__repr__()
Convert to string