Wall Properties
Class full path: NemAll_Python_ArchElements.WallProperties
Implementation of the wall properties
Attributes
Axis: AchseDataT
property
writable
Get the axis properties
IsStartNewJoinedWallGroup: bool
property
writable
Get the state for starting a new wall group
All walls in a group are used for to create a continues join between the walls.
PathElementAxisType: int
property
writable
Get the axis type of the path element
TierCount: int
property
writable
Get the tier count
Functions
GetAxis()
Get the axis properties
Returns:
Type | Description |
---|---|
AxisProperties
|
Axis properties |
GetPathElementAxisType()
Get the axis type of the path element
GetTierCount()
Get the tier count
Returns:
Type | Description |
---|---|
int
|
Tier count |
GetWallTierProperties(tierIndex)
Get the wall tier properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
tierIndex
|
int
|
Tier index |
required |
Returns:
Type | Description |
---|---|
WallTierProperties
|
Wall tier properties |
LoadFromFavoriteFile(doc)
Load the properties from the favorite file
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
SetAxis(axis)
Set the axis
Parameters:
Name | Type | Description | Default |
---|---|---|---|
axis
|
AxisProperties
|
Axis properties |
required |
SetPathElementAxisType(pathEleAxisType)
Set the axis type of the path element
Parameters:
Name | Type | Description | Default |
---|---|---|---|
pathEleAxisType
|
int
|
Axis type of the path element |
required |
SetTierCount(tierCount)
Set the tier count
Parameters:
Name | Type | Description | Default |
---|---|---|---|
tierCount
|
int
|
Tier count |
required |
__init__
overload
__init__()
Initialize
__init__(wallProp)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
wallProp
|
WallProperties
|
Wall properties |
required |
__repr__()
Convert to string