Attribute Set
Class full path: NemAll_Python_BaseElements.AttributeSet
Attribute set
Attributes
Attributes: typing.List[typing.Union[AttributeByteVec, AttributeDate, AttributeDouble, AttributeDoubleVec, AttributeEnum, AttributeInteger, AttributeIntegerVec, AttributeString, AttributeStringVec]]
property
writable
Return type: typing.List[typing.Union[AttributeByteVec, AttributeDate, AttributeDouble, AttributeDoubleVec, AttributeEnum, AttributeInteger, AttributeIntegerVec, AttributeString, AttributeStringVec]]
Get the AttributeSet vector
Functions
GetAttributes()
Get the AttributeSet vector
Returns:
Type | Description |
---|---|
List[Union[AttributeByteVec, AttributeDate, AttributeDouble, AttributeDoubleVec, AttributeEnum, AttributeInteger, AttributeIntegerVec, AttributeString, AttributeStringVec]]
|
Vector of Attribute elements |
SetAttributes(elements)
Set the AttributeSet vector
Parameters:
Name | Type | Description | Default |
---|---|---|---|
elements
|
List[Union[AttributeByteVec, AttributeDate, AttributeDouble, AttributeDoubleVec, AttributeEnum, AttributeInteger, AttributeIntegerVec, AttributeString, AttributeStringVec]]
|
Attribute elements |
required |
__eq__(element)
Equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
AttributeSet
|
Element to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Elements are equal: true/false |
__init__
overload
__init__()
Initialize
__init__(elements)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
elements
|
list
|
Attribute elements |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
AttributeSet
|
Element to copy |
required |
__ne__(element)
Unequal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
AttributeSet
|
Element to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
Elements are unequal: true/false |
__repr__()
Convert to string