Document Resource Service
Class full path: NemAll_Python_BaseElements.DocumentResourceService
Functions
CreateSurface(doc, surfaceDirectoryPath, localPathAndName, surfaceDef, createUniqueName=True, bitmapDefinitions={})
staticmethod
Create a surface resource with a unique name
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
surfaceDirectoryPath
|
str
|
Path to the surface directory (e.g. ...\std\design) |
required |
localPathAndName
|
str
|
Local path and name (extends the surface directory path) |
required |
surfaceDef
|
SurfaceDefinition
|
Surface definition |
required |
createUniqueName
|
bool
|
create a unique name state |
True
|
bitmapDefinitions
|
Dict[eSurfaceTextureID, BitmapDefinition]
|
Bitmap definitions |
{}
|
Returns:
Type | Description |
---|---|
str
|
Unique name extension of the surface |