Drawing File Load State
Class full path: NemAll_Python_BaseElements.DrawingFileLoadState
Bases: IntEnum
Load state of the drawing file
Attributes
ActiveBackground = 2
class-attribute
instance-attribute
ActiveForeground = 3
class-attribute
instance-attribute
PassiveBackground = 1
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
DrawingFileLoadState
|
value for the key |