Drawing File Service
Class full path: NemAll_Python_BaseElements.DrawingFileService
Bases: ExportImportService
Functions
CreateBendingSchedule(doc, refPnt)
Create a bending schedule
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
refPnt
|
Point2D
|
Reference point of the bending schedule |
required |
DeleteDocument(doc)
Delete the context of the active document Args: doc: Document
ExportBendingMachine(doc, fileName, project, plan, index, bSplitGroups)
Export the reinforcement data for the bending machine
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
fileName
|
str
|
Name of the output file |
required |
project
|
str
|
Name of the project |
required |
plan
|
str
|
Name of the plan |
required |
index
|
str
|
Index as text |
required |
bSplitGroups
|
bool
|
Split the reinforcement groups |
required |
GetActiveFileNumber()
staticmethod
Get the drawing file number of the active document
GetFileState()
Get the file state of all loaded drawing files Returns: list with a tuple(file index, drawing file load state)
LoadFile(doc, fileIndex, loadState)
Load a drawing file
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
fileIndex
|
int
|
Index of the drawing file |
required |
loadState
|
DrawingFileLoadState
|
File load state |
required |
SetScalingFactor(arg2, arg3)
UnloadAll(doc)
Unload all drawing files
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
UnloadFile(doc, fileIndex)
Unload a drawing file
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
fileIndex
|
int
|
Index of the drawing file |
required |
__init__()
Initialize