Drawing Service
Class full path: NemAll_Python_BaseElements.DrawingService
Functions
LockGraphicsEngineUpdate(doc, lockUpdate)
staticmethod
Lock the update of the graphics engine Args: doc: Document lockUpdate: True: Lock the update of the graphics engine False:: Unlock the update of the graphics engine and update the graphics engine
RedrawAll(doc)
staticmethod
Redraw all Args: doc: Document
ResetAndDrawHiddenElement(doc, hiddenElement)
staticmethod
Reset and draw the hidden elements Args: doc: Document hiddenElement: Hidden element
UpdateAllWindows()
staticmethod
Update the drawing in all windows
UpdateGraphicsEngine(doc)
staticmethod
Update the graphics engine Args: doc: Document