Drawing Type Service
Class full path: NemAll_Python_BaseElements.DrawingTypeService
Implementation of the drawing type service
Classes
DefaultDrawingTypes
Bases: IntEnum
Definition of the default drawing types
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
DefaultDrawingTypes
|
value for the key |
Functions
GetCurrentDrawingTypeDescription(doc)
staticmethod
Get the description of the current drawing type
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
GetCurrentDrawingTypeId(doc)
staticmethod
Get the current drawing type ID
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
GetDrawingTypeDescription(doc, drawingTypeId)
staticmethod
Get the description of the drawing type
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
drawingTypeId
|
int
|
Drawing type ID |
required |
GetDrawingTypeDescriptions(doc)
staticmethod
Get the description of the drawing types
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
GetDrawingTypeIdFromDescription(doc, typeDescription)
staticmethod
Get the ID of the drawing type from the description
Parameters:
Name | Type | Description | Default |
---|---|---|---|
doc
|
DocumentAdapter
|
Document |
required |
typeDescription
|
str
|
Drawing type description |
required |
SetDrawingTypeId(drawingTypeId)
staticmethod
Set the drawing type ID
Parameters:
Name | Type | Description | Default |
---|---|---|---|
drawingTypeId
|
int
|
ID of the drawing type |
required |