Elements Attribute Service
Class full path: NemAll_Python_BaseElements.ElementsAttributeService
Functions
ChangeAttribute(attributeNumber, newValue, elements)
staticmethod
Change an attribute
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributeNumber
|
int
|
Attribute number |
required |
newValue
|
object
|
New value |
required |
elements
|
BaseElementAdapterList
|
Elements |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Adapted elements |
ChangeAttributes(attributeDataList, elements)
staticmethod
Change an attribute
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributeDataList
|
list
|
List with the attribute data as tuple(number, value) |
required |
elements
|
BaseElementAdapterList
|
Elements as BaseElementAdapterList |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Modified elements |
GetAttributes(ele, readState=ReadAll)
staticmethod
Get the attributes from an element
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
Element |
required |
Returns:
Type | Description |
---|---|
list
|
Attributes |