Elements By Attribute Service
Class full path: NemAll_Python_BaseElements.ElementsByAttributeService
Implementation of the elements by attribute service
Functions
GetElements
overload
GetElements(attributeValue)
Get the elements for the double attribute value
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributeValue
|
float
|
Attribute value |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Elements |
GetElements(attributeValue)
Get the elements for the integer attribute value
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributeValue
|
int
|
Attribute value |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Elements |
GetElements(attributeValue)
Get the elements for the string attribute value
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributeValue
|
str
|
Attribute value |
required |
Returns:
Type | Description |
---|---|
BaseElementAdapterList
|
Elements |
GetInstance()
staticmethod
Get the instance
Returns:
Type | Description |
---|---|
ElementsByAttributeService
|
Instance of the singleton |
Init(attributeID, doc)
Initialize the service.
Parameters:
Name | Type | Description | Default |
---|---|---|---|
attributeID
|
int
|
Attribute ID. Used for creating fast element access by an attribute value of this ID |
required |
doc
|
DocumentAdapter
|
Document |
required |