IFC_ Version
Class full path: NemAll_Python_BaseElements.IFC_Version
Bases: IntEnum
IFC version
Attributes
Ifc_2x3 = 4
class-attribute
instance-attribute
Ifc_4 = 7
class-attribute
instance-attribute
Ifc_XML_2x3 = 5
class-attribute
instance-attribute
Ifc_XML_4 = 8
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
IFC_Version
|
value for the key |