e Attibute Read State
Class full path: NemAll_Python_BaseElements.eAttibuteReadState
Bases: IntEnum
Attribute read state
Attributes
DoNotRead = 2
class-attribute
instance-attribute
ReadAll = 1
class-attribute
instance-attribute
ReadAllAndComputable = 3
class-attribute
instance-attribute
ReadWithoutGeometry = 0
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
eAttibuteReadState
|
value for the key |