ARGB
Class full path: NemAll_Python_BasisElements.ARGB
ARGB class
Attributes
Alpha: None
property
Property for alpha channel
:type: None
Blue: None
property
Property for blue channel
:type: None
Green: None
property
Property for green channel
:type: None
Red: None
property
Property for red channel
:type: None
Functions
GetARGB()
returns color as unsigned long
Returns:
Type | Description |
---|---|
int
|
color as long |
__eq__(argb)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
argb
|
ARGB
|
color to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal |
__init__
overload
__init__()
Initialize
__init__(red, green, blue, alpha)
constructor with RGBA components
Parameters:
Name | Type | Description | Default |
---|---|---|---|
red
|
int
|
red component |
required |
green
|
int
|
green component |
required |
blue
|
int
|
blue component |
required |
alpha
|
int
|
alpha component |
required |
__init__(argb)
constructor with ARGB color
Parameters:
Name | Type | Description | Default |
---|---|---|---|
argb
|
int
|
ARGB color |
required |
__init__(argb)
copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
argb
|
ARGB
|
copy from |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |