Associative View Element Representation
Class full path: NemAll_Python_BasisElements.AssociativeViewElementRepresentation
Bases: IntEnum
Element representation of the associative view
Attributes
AssociativeViewAllElements = 0
class-attribute
instance-attribute
AssociativeViewConcreteShape = 3
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
AssociativeViewElementRepresentation
|
value for the key |