Clipping Path Properties
Class full path: NemAll_Python_BasisElements.ClippingPathProperties
Clipping properties
Attributes
BottomLevel: None
property
Get/set the bottom level
:type: None
IsClippingLineOn: None
property
Get/set the clipping line state
:type: None
IsHeightFromElementOn: None
property
Get/set the height from element state
:type: None
SectionIdentifier: None
property
Get/set the section identifier
:type: None
SectionType: None
property
Property for type of section
:type: None
TopLevel: None
property
Get/set the top level
:type: None
Classes
SectionType_Enum
Bases: IntEnum
Section type
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
SectionType_Enum
|
value for the key |
Functions
__init__()
Initialize