End Symbols Properties
Class full path: NemAll_Python_BasisElements.EndSymbolsProperties
EndSymbolsProperties class
Attributes
EndID: None
property
Property for end symbol ID
:type: None
EndSize: None
property
Property for end symbol size
:type: None
StartID: None
property
Property for start symbol ID
:type: None
StartSize: None
property
Property for start symbol size
:type: None
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
EndSymbolsProperties
|
EndSymbolsProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__
overload
__init__()
Initialize
__init__(startID, startSize, endID, endSize)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
startID
|
int
|
ID of the start symbol |
required |
startSize
|
float
|
Size of the start symbol |
required |
endID
|
int
|
ID of the end symbol |
required |
endSize
|
float
|
Size of the end symbol |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |