Face Style Properties
Class full path: NemAll_Python_BasisElements.FaceStyleProperties
FaceStyleProperties class
Attributes
DirectionToReferenceLine: None
property
Property for direction to reference line
:type: None
FaceStyleID: None
property
Property for face style ID
:type: None
ReferencePoint: None
property
Property for reference point
:type: None
RotationAngle: None
property
Property for rotation angle
:type: None
UseDirectionToReferenceLine: None
property
Property for usage of direction to reference line
:type: None
UseReferencePoint: None
property
Property for usage of reference point
:type: None
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
FaceStyleProperties
|
FaceStyleProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
Initialize
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |