Filling Properties
Class full path: NemAll_Python_BasisElements.FillingProperties
FillingProperties class
Attributes
DirectionToReferenceLine: None
property
Property for direction to reference line
:type: None
FirstColor: None
property
Property for first color
:type: None
RotationAngle: None
property
Property for rotation angle
:type: None
SecondColor: None
property
Property for first color
:type: None
ShadingType: None
property
Property for shading type
:type: None
TranslationType: None
property
Property for color type
:type: None
UseDirectionToReferenceLine: None
property
Property for usage of direction to reference line
:type: None
UseGradientFilling: None
property
Property for usage of gradient filling type
:type: None
VariantType: None
property
Property for variant type
:type: None
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
FillingProperties
|
GradientFillingProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__()
Initialize
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |