Hatching Element
Class full path: NemAll_Python_BasisElements.HatchingElement
Bases: BasisElement
, AllplanElement
Implementation of the hatching element
Attributes
HatchingProperties: HatchingProperties
property
writable
Get the hatching properties
Functions
GetHatchingProperties()
Get the hatching properties
Returns:
Type | Description |
---|---|
HatchingProperties
|
Hatching properties |
SetHatchingProperties(hatchingProp)
Set the hatching properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
hatchingProp
|
HatchingProperties
|
Hatching properties |
required |
__init__
overload
__init__()
Initialize
__init__(commonProp, hatchingProp, polygon)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
commonProp
|
CommonProperties
|
Common properties |
required |
hatchingProp
|
HatchingProperties
|
Hatching properties |
required |
polygon
|
Polygon2D
|
Geometry element |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
HatchingElement
|
Element to copy |
required |
__repr__()
Convert to string