Label Element
Class full path: NemAll_Python_BasisElements.LabelElement
Bases: BasisElement
, AllplanElement
Implementation of the Label element
Functions
AddTextElement(text)
Add a text element
Parameters:
Name | Type | Description | Default |
---|---|---|---|
text
|
TextElement
|
Text element |
required |
SetLabeledElement(labeledElement)
Set the labeled element
Parameters:
Name | Type | Description | Default |
---|---|---|---|
labeledElement
|
BaseElementAdapter
|
Labeled element |
required |
__init__
overload
__init__()
Initialize
__init__(text, labelType)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
text
|
TextElement
|
Text element |
required |
labelType
|
LabelType
|
Default text |
required |
__init__(textElements, labelType)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
textElements
|
TextElementList
|
Text elements |
required |
labelType
|
LabelType
|
Label type |
required |
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
LabelElement
|
Element to copy |
required |
__repr__()
Convert to string