Library Element Properties
Class full path: NemAll_Python_BasisElements.LibraryElementProperties
Implementation of the library element properties
Attributes
PlacementMatrices: NemAll_Python_Geometry.Matrix3DList
property
writable
Get the placement matrices
PlacementMatrix: NemAll_Python_Geometry.Matrix3D
property
writable
Get the placement matrix
Polyline: NemAll_Python_Geometry.Polyline3D
property
writable
Get the polygon points in case of a line fixture
Producer: str
property
writable
Get the producer
Functions
GetElement()
Get the element
Returns:
Type | Description |
---|---|
str
|
Element |
GetElementType()
Get the element type
GetGroup()
Get the group
Returns:
Type | Description |
---|---|
str
|
Group |
GetPath()
Get the path
Returns:
Type | Description |
---|---|
str
|
Path |
GetPlacementMatrices()
Get the placement matrices
Returns:
Type | Description |
---|---|
Matrix3DList
|
Placement matrices |
GetPlacementMatrix()
Get the placement matrix
Returns:
Type | Description |
---|---|
Matrix3D
|
Placement matrix |
GetPolyline()
Get the polygon points in case of a line fixture
Returns:
Type | Description |
---|---|
Polyline3D
|
Polyline points of the line fixture |
GetProducer()
Get the producer
Returns:
Type | Description |
---|---|
str
|
Producer |
GetSingleFilePath()
Get the Single File Path
Returns:
Type | Description |
---|---|
str
|
SingleFilePath |
SetPlacementMatrices(placementMatrices)
Set the placement matrices
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placementMatrices
|
Matrix3DList
|
Placement matrices |
required |
SetPlacementMatrix(placementMatrix)
Set the placement matrix
Parameters:
Name | Type | Description | Default |
---|---|---|---|
placementMatrix
|
Matrix3D
|
Placement matrix |
required |
SetPolyline(polyline)
Set the polygon points in case of a line fixture
Parameters:
Name | Type | Description | Default |
---|---|---|---|
polyline
|
Polyline3D
|
Polyline of a line fixture |
required |
SetProducer(producer)
Set the producer
Parameters:
Name | Type | Description | Default |
---|---|---|---|
producer
|
str
|
Producer |
required |
__init__
overload
__init__()
Initialize
__init__(fullPathName, elementType, placementMatrix)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
fullPathName
|
str
|
Full path and file name |
required |
elementType
|
LibraryElementType
|
Element type |
required |
placementMatrix
|
Matrix3D
|
Placement matrix |
required |
__init__(fullPathName, elementType, placementMatrices)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
fullPathName
|
str
|
Full path and file name |
required |
elementType
|
LibraryElementType
|
Element type |
required |
placementMatrices
|
Matrix3DList
|
Placement matrices |
required |
__init__(path, group, element, elementType, placementMatrix)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
path
|
str
|
Path name |
required |
group
|
str
|
Group name |
required |
element
|
str
|
Element name |
required |
elementType
|
LibraryElementType
|
Element type |
required |
placementMatrix
|
Matrix3D
|
Placement matrix |
required |
__init__(path, group, element, elementType, placementMatrices)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
path
|
str
|
Path name |
required |
group
|
str
|
Group name |
required |
element
|
str
|
Element name |
required |
elementType
|
LibraryElementType
|
Element type |
required |
placementMatrices
|
Matrix3DList
|
Placement matrices |
required |
__init__(arg2, path, group, element, elementType, placementMatrix)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
path
|
str
|
Path name |
required |
group
|
str
|
Group name |
required |
element
|
str
|
Element name |
required |
SingleFilePath
|
SingleFilePath |
required | |
elementType
|
LibraryElementType
|
Element type |
required |
placementMatrix
|
Matrix3D
|
Placement matrix |
required |
__init__(arg2, path, group, element, elementType, placementMatrices)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
path
|
str
|
Path name |
required |
group
|
str
|
Group name |
required |
element
|
str
|
Element name |
required |
SingleFilePath
|
SingleFilePath |
required | |
elementType
|
LibraryElementType
|
Element type |
required |
placementMatrices
|
Matrix3DList
|
Placement matrices |
required |