Library Element Type
Class full path: NemAll_Python_BasisElements.LibraryElementType
Bases: IntEnum
Attributes
eFixture = 1
class-attribute
instance-attribute
eFixtureSingleFile = 3
class-attribute
instance-attribute
eSmartSymbol = 0
class-attribute
instance-attribute
eSymbol = 2
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
LibraryElementType
|
value for the key |