Link Type
Class full path: NemAll_Python_BasisElements.LinkType
Bases: IntEnum
Definition of link type
eLinkNothing : Link to nothing eLinkToRoom : Link to a room object eLinkToRoofSlab : Link to a roof slab object eLinkToCeilingSurface: Link to a ceiling surface object eLinkToFloorSurface : Link to a floor surface object
Attributes
eLinkNothing = 0
class-attribute
instance-attribute
eLinkToCeilingSurface = 3
class-attribute
instance-attribute
eLinkToFloorSurface = 4
class-attribute
instance-attribute
eLinkToRoofSlab = 2
class-attribute
instance-attribute
eLinkToRoom = 1
class-attribute
instance-attribute
Functions
__getitem__(key)
get the item for a key
Parameters:
Name | Type | Description | Default |
---|---|---|---|
key
|
str | int | float
|
value key |
required |
Returns:
Type | Description |
---|---|
LinkType
|
value for the key |