Macro Element
Class full path: NemAll_Python_BasisElements.MacroElement
Bases: BasisElement
, AllplanElement
MacroElement class
Functions
GetHash()
Get the hash value
Returns:
Type | Description |
---|---|
str
|
Hash value |
GetMacroProperties()
Get the Macro properties
Returns:
Type | Description |
---|---|
MacroProperties
|
Macro properties |
GetSlideList()
Get the slide object list
Returns:
Type | Description |
---|---|
list
|
Slide object list |
SetHash(hash)
Set the hash value
Parameters:
Name | Type | Description | Default |
---|---|---|---|
hash
|
str
|
Hash value |
required |
SetMacroProperties(MacroProp)
Set the Macro properties
Parameters:
Name | Type | Description | Default |
---|---|---|---|
MacroProp
|
MacroProperties
|
Macro properties |
required |
__init__
overload
__init__()
Initialize
__init__(macroProp, slideList)
Constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
macroProp
|
MacroProperties
|
Macro properties |
required |
slideList
|
list
|
Slide list of macro definition |
required |
__repr__()
Convert the list to a string
Returns:
Type | Description |
---|---|
str
|
List values as string |