Macro Group Properties
Class full path: NemAll_Python_BasisElements.MacroGroupProperties
Implementation of the macro group element properties
Attributes
Name: str
property
writable
Get the Name
Functions
__eq__(prop)
equal operator
Parameters:
Name | Type | Description | Default |
---|---|---|---|
prop
|
MacroGroupProperties
|
MacroGroupProperties to compare |
required |
Returns:
Type | Description |
---|---|
bool
|
true if they are equal, false otherwise |
__init__
overload
__init__()
Initialize
__init__(element)
Copy constructor
Parameters:
Name | Type | Description | Default |
---|---|---|---|
element
|
MacroGroupProperties
|
Element to copy |
required |
__repr__()
Convert to string